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1 Introduction 
The SOP application is used for the generation of handset data (customer and product extracts), 

entering of sales orders and the processing of imported handheld (remote) sales orders. 

This manual is meant for the users of the system and describes the most commonly used functions 

within the application. 

This guide does not cover the installation or configuration of the SOP system, nor the operation of the 

handheld software.  These are covered in separate related documents, available on request. 

2 Conventions 
Throughout this manual several conventions are used to highlight menu commands and interaction that 

the user must take.   

2.1 Menu Commands 
If the user is required to click on a menu command, the name of the command is given in bold italic 

font.  If the user must navigate through a hierarchy of such menu commands then each command is 

separated by the → character.  For example: 

Tools → Synchronise → Head Office → Import Data From Back Office 

Indicates the user should 

first click on the ‘Tools’ 

menu, then on the 

‘Synchronise’ sub menu, 

then the ‘Head Office’ sub 

menu and finally the ‘Import 

Data From Back Office’ menu item as shown in Figure 2-1. 

 

2.2 Button Commands 
In a similar way to menu commands, button presses are indicated to the user by bold italic font.  Simply 

click on the button with the relevant text. 

Figure 2-1 - Menu Command 
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3 Login 
To login to SOP, click the SOP icon in the 

Start Menu.  This will bring up the SOP 

splash screen and the application will load.  

You will then be presented with the login 

screen as shown in Figure 3-1. 

Enter ‘Manager’ in the user name field and 

leave password blank, then press OK. 

When you login for the first time, your 

User Name will be manager and the 

password will be blank.  Change this as 

soon as you can by following the 

instructions in section 17.5. 

4 Importing Back Office Data 
Once you have set up your company and configured the parameters, you are ready to import your back 

office data into SOP.  This will allow you to access all your product and customer information and export 

the data that is required by the handheld devices (see section 5 for more information).  

To manually import the back office data, go to the Tools → Synchronise → Head Office → Import Data 

From Back Office. 

After the import is complete, handheld data is automatically generated and placed on the server, ready 

for download to the handheld devices. 

If any errors occur with the data import or handheld data generation processes, they can have a serious 

effect on the remote ordering system as a whole.  If any error messages occur, contact Computoy as a 

matter of urgency. 

5 Creating Handheld Lookups 
In order for the mobile sales reps to place orders using the handheld devices, they must download 

customer, product and related data.  This data is contained in ‘lookups’ which need to periodically 

generated to ensure they are up to date.  Full lookups are generated each time the back office data is 

imported into SOP, but updates can be generated manually by clicking 

Tools → Synchronise → Handhelds →Export Handheld Updates 

Figure 3-1 - Login Screen 
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This will create updates for each of the reps and place them on the server ready for download to the 

handhelds.  These update files are smaller than the original full extracts and only contain new or 

updated records so that the reps can load their device with the latest data, without having to download 

the full data extract.  

6 Entering an Order 
Once the back office data has been 

imported into SOP, all of your customers 

and products will be available for you to 

create sales orders. 

In addition to being able to enter sales 

orders on the handheld devices, you can 

manually input orders directly into the 

SOP. 

To open the order entry screen, click on 

the New Order icon on the top left of the 

main screen.  The standard order entry 

screen is displayed as shown in Figure 

6-1. 

6.1 Assigning a customer to an order 
The first task is to assign a customer to this order; this is 

done by clicking the Search button next to the Acc. Ref 

field.  Alternatively you can enter the customer account 

code in this field and press the Tab key.  The customer’s 

details will be loaded to screen. 

6.1.1 Customer Lookup Form 

If the search button is used, you will be presented with the 

customer lookup box as shown in Figure 6-2. 

Search for a customer by entering any part of their 

account code, name or postcode in the relevant fields.   

Pressing return or clicking Search will filter the list of 

customers in the grid below.  Double click the relevant 

customer record to load their details to the order entry 

form. 

Figure 6-1 - Order Entry Screen 

Figure 6-2 - Customer Lookup Form 
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6.2 Delivery Address Selection 
Once the customer is selected, the required delivery address for this particular order can be selected 

using the slider under the delivery address details.  A new delivery address can be created for this 

customer by clicking the New… button. 

6.3 Adding Products to an Order 
To start adding products to an order, click the Add button next to 

the order line details grid. 

This brings up the order line entry form as shown in Figure 6-3.  If 

the product code is not known then you can search for it by clicking 

the search button.  Alternatively, you can enter the product code 

into the Stock Code field and press Tab to load the details to screen. 

 

 

 

 

You can select a selling price per unit from the prices drop down.  

The default price is the customer special price (if it exists) and the 

standard list price (if it doesn’t).  The selling price can be changed 

manually by typing it into the Item Price field.  The equivalent 

discount from the list price is calculated and show in the Discount % 

field.  Conversely, you can enter the discount into the Discount % field and the item Price will be 

calculated and displayed in the Item Price field. 

You can enter the quantity required using the up/down arrows next to the Pieces or Units fields.  The 

Qty Mode drop down box can be used to change the increments in which the quantities are increased.  

Changing the unit of measure in the Qty Mode drop down box changes the increment by which the 

Units field is increased. 

If either of the Pieces or Units fields are changed manually then the other is calculated automatically.  

The quantity that is shown on the order line is always in units.  In this way you can always check you 

have entered the desired quantity correctly. 

The order line is added to the order by clicking the Add button.  The view is then returned to the order 

entry screen. 

6.4 Completing an Order 
Continue to add items to the order until all the desired items are listed in the order lines grid.  Once all 

the items are added, there are a number of options that can be set to customise how the order is 

Figure 6-3 - Order Line Entry Screen 

When a product is selected, any special prices for the 

product that apply to the currently selected customer are 

automatically calculated and loaded to the Prices drop-

down box.  The equivalent discount from the list price is 

also calculated and shown in the Discount % field. 
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processed.  These are on the right side of the order entry screen as shown in Figure 6-4 and are 

explained in section 6.4.1 below. 

6.4.1 Order Options 

1. Order Type 

An order can be one of three types: 

• Order 

• Pro-forma 

• Quote 

Select the type that is relevant to this order using the dropdown 

box.  Depending on which of these types is selected, the order is 

processed in different ways.  See section 0 for details on how 

certain order types can be held in the system. 

2. Source 

The field is for recording where the order was taken.  The values 

in this list are taken from the order sources defined in the system.  

See section 17.2 for more details. 

3. Rep 

This is the rep that is responsible for this order (if applicable).  This field should hardly ever be changed 

because it defaults to the customer’s normal sales rep. 

4. Purchase Order Ref 

Enter a customer purchase order reference here if desired.  It will be printed on the order 

acknowledgement. 

5. Order Date 

This defaults to today’s date but can be changed so that you can enter a post dated sales order. 

6. Reqd Date 

This defaults 30 days the future but can be changed to reflect the date that the customer requires the 

order by. 

7. Expected date 

This is a read-only field that shows when all the lines in an order will be available for dispatch and is 

calculated as the latest date of any outstanding purchase orders. 

8. Currency 

Change the currency of the order here.  See section 17.3 for more details on administering currencies 

within the system. 

Figure 6-4 - Order Options 
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9. Confirmation Type 

This can be set to one of three options: 

• By Post – Confirmation will be printed and sent manually by post, no action is taken by the SOP 

system 

• By E-mail – Confirmation will be generated and sent via email to the customer.  When selecting 

this option, an e-mail address must be entered into the Email Address field.  When the order is 

added to the system, it is automatically queued for sending.  For more details on the e-mailing 

functionality see section 0. 

• By B2B portal – (Future Development) – Send confirmation to your customer using your chosen 

Business to Business (B2B) portal. 

10. Order Taken By 

Enter your initials here. 

11. Terms & Customer discount 

These are information fields that give information regarding the customer that has been associated with 

this order. 

6.4.2 Adding an order 

Once you are happy with all the details of an order, it can be added to the system by clicking the Save 

Order button on the toolbar. 

7 Importing Handheld Orders 
Once your sales team have been out collecting sales orders on the handheld devices and have sent 

those orders back to Head Office, you must import them into SOP to process them further.   

To import any new orders from the handheld devices, click the Import Handheld Orders on the toolbar.  

The SOP will search for 

any new handheld orders 

and load them into the 

current orders grid as 

shown in Figure 7-1. 

If the order is being held 

for any reason, this is 

indicated by a tick in the Hold column.  Orders can be held for a number of reasons that are configured 

using the Order Hold Reasons dialog as described in section 0. 

Figure 7-1 - Current Orders Grid 
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8 Reviewing Orders 

8.1 Editing Orders 
You can edit an order by double clicking it in the current orders grid (click the Orders button on the 

toolbar).  This allows you to change any aspect of the order in much the same way as entering a new 

order as described in section 6.   

You will be warned of you are attempting to edit an order that has already been exported to the back 

office.  If such an order is modified then it will be exported again, the next time that a back office export 

is generated.  

8.2 Deleting orders 
An order can be deleted by highlighting it and clicking the Delete Order button on the toolbar.   

9 Order Printing 
You can print an order acknowledgment by highlighting the relevant order and clicking the Print button.  

This will print the order acknowledgment on the default printer using the layout selected when the rep 

entered the order.  The default layout for this is the text acknowledgement layout.  If you would like to 

preview this printout before printing, or you would like to change the layout of the acknowledgement, 

click the Print Preview button.  This will open a dialog asking you to confirm the desired layout for 

printing.  The three options are: 

• Default Acknowledgement 

• Small photo acknowledgment 

• Large photo acknowledgment 

Once you have chosen the required layout, you can also select a sorting order for the products on the 

order.  The three options are: 

• By product code 

• By product description 

• By sequence entered – this option displays the items in the report in the sequence they were 

entered into either SOP or the handheld device. 

Clicking the View/Print button brings up your selected order acknowledgement from where you can 

print it or export it to PDF. 

 
 



10 | P a g e  
 

10 E-mailing an Order 
By setting the confirmation type of an order to E-

mail, either using the handheld or SOP (see 

section 6.4.1), the order acknowledgment is 

automatically generated as a PDF.  This PDF is then 

attached to an e-mail and sent to the e-mail 

address given when entering the order.   

When an order is added to the e-mailing queue, 

two icons appear in the Confirm By and Send 

Status columns in the order grid as shown in Figure 10-1.  The envelope icon in the Confirm by column 

indicates that the chosen method for acknowledgement is e-mail.  The same icon in the Send Status 

column indicates that the order has been successfully added to the e-mail queue.  This means that at 

scheduled intervals the SOP will attempt to generate and send the e-mail.  Successful transmission of 

this e-mail is indicated by the Sent icon ( ).  In the time between the PDF generation and the sending 

of the e-mail the Send Status column will display ‘1’.  

If the sending of the email fails for any reason then the failed icon ( ) will be displayed in the Send 

Status column.  It is recommended that you manually send the order acknowledgement (located in the 

PDF folder within your company’s data folder) and contact support to resolve this issue.  

11 Exporting Orders to Back Office 
Once orders have been gathered from the handhelds, entered and edited in SOP, they need to be 

exported to Intact for further processing.  To export all current orders to Intact, click Tools → 

Synchronise → Head Office → Export Orders. 

To stop individual orders from being included in the export they must be placed on manual hold.  Open 

the order for editing and tick the On Hold checkbox then click on the Save Order button.  Note that 

orders that are held for other reasons will also be excluded from the export and will remain in the 

current orders view. 

When orders have been exported to back office they are still available for review (see section 8) by 

clicking the drop down arrow next to the Orders button on the toolbar and selecting Exported Orders. 

A list of all orders is available by clicking the drop down arrow next to the Orders button and selecting 

All Orders. 

12 Reporting 
SOP offers numerous reports to enable supervisors or managers to easily view information that is crucial 

to running successful sales operations. 

Figure 10-1 - Email Status 
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12.1 Day End Summary 
This report shows a list of the orders from a particular date 

range.  To access this report click Reports → Orders Reports 

→ Day End Summary.  This will open a dialog as shown in 

Figure 12-1. 

Select the date range you are interested in using the From 

and To fields.  You can opt to view all orders, exported 

(processed) orders or current orders by using the Order 

Status radio buttons.  Use the Include Orders on Hold 

checkbox to also include orders that are on hold.  You can 

also opt to view orders of a particular type using the Order 

Type radio buttons. 

The Create a new page for each Rep checkbox means that the orders for each rep will be on a new page 

in the report, with a summary of all the orders on the last page. 

 Clicking on Ok will generate the report, after which you can print it or export it to PDF. 

12.2 Held Orders  
This report gives a list of all orders that are currently on hold within the SOP system and the reasons for 

them being held.  To access this report click Reports →Orders Reports → Held Orders.  The report is 

generated and shown, ready for printing or exporting to PDF. 

12.3 Top 20 Reports 
These three reports show the top 20 products according to value sold, quantity sold or cartons sold.  To 

access these reports click Reports → Products Reports → Top 20 then select the desired report from the 

three options. 

12.4 Below Price 
This report gives you a detailed view of which products have been sold below ‘normal price’.  In this case 

the ‘normal price’ that the report uses is the customer special price given by the pricing structure and 

discount matrix.    To show this report click Reports → Products Reports → Below Price Report. 

12.5 Oversold Report 
This report lists order lines that have been sold without the total order quantity being available in stock.  

The report also shows the quantity on purchase order of each oversold line for planning purposes.  To 

generate this report click Reports → Product Reports → Oversold Report. 

Figure 12-1 - Day End Summary 
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13 Product Administration 
Once product information has been imported 

into SOP (see section 3) it can be viewed in SOP 

by clicking the Products button on the toolbar. 

13.1 Editing Product Data 
Double click on a product in the product grid to 

load the Product Details form as shown in Figure 

13-1. 

The information relating to the product is split up 

into four tabs.  This data can be changed then 

saved by clicking the OK button. 

The stock tab provides a view of any purchase 

orders that are currently outstanding for this 

product as well as current stock information. 

13.2 Printing Product Photos 
Product photos can be printed by right clicking on the products grid and selecting Product Photos or by 

clicking Reports → Product Reports → Product Photos.  This brings up the Product Photo Selection 

dialog with which you can select whether to print all product photos, the current filter (search results) or 

just the current selection.  If a selection of product photos is required then ensure that the desired 

products are selected in the products grid before opening this dialog.  The Current Filter option will only 

be available if a search has taken place on the products grid.  Clicking OK generates the Product Photos 

Report ready for printing or export to PDF. 

13.3 Printing Product Barcodes 
In a similar way to product photos, product barcodes can be printed for labelling purposes etc.  These 

barcodes can then be scanned during the sales order entry process on compatible handheld devices.  

This scanning of barcodes means that your sales reps will not have to search for the correct product, 

thus reducing mistakes and speeding up the order taking process. 

To print product barcodes right click on the products grid and select Product Barcodes or click Reports 

→ Product Reports → Product Photos.  This will open the Product Barcode Selection dialog.  If a 

selection of barcodes is required then ensure this selection is made before opening this dialog.  The 

current filter option will only be available if a search has been carried out on the product grid before 

opening the selection dialog.  Clicking OK generates the Product Barcodes Report ready for printing or 

export to PDF. 

14 Customer Administration 

Figure 13-1 - Product Details Form 
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Once the back office data has been 

imported into SOP, the customer 

information can be viewed by 

clicking the Customers button on 

the toolbar. 

14.1 Editing Customer 

Data 
 Double click a customer in the 

customers’ grid to load the 

Customer details form as shown in 

Figure 14-1.  

The information on this form is 

divided into tabs for easy 

navigation.  Simply click on the relevant tab to edit the desired data.  Clicking OK will save the changes. 

14.1.1 Default Sales Reps 

The setting on the Default Sales Reps tab affects how handheld lookups are generated for this customer.  

Using this tab, it is possible to define one or more default sales reps for this customer.  If a rep is 

associated with a customer in this way then this customer data will be available on their handheld 

device i.e. this customers data will be included in their lookup files.  Note that the customer’s data will 

not be available immediately.  Lookups must be generated then the rep is required to do an update on 

their handheld before the extended coverage is visible. 

 

 

 

14.2 Printing Customer Barcodes 
A customer listing report can be generated for SOP that includes barcodes so sales reps can quickly load 

a customer’s details to screen when entering a handheld order.  Select Reports → Customer Reports → 

Customer Listing to launch this report.  The Customer Report dialog is shown which allows the listing for 

a particular rep to be selected.  Clicking the View/Print button generates the report for printing or 

exporting to PDF. 

15 Previous Transactions 
If the data is available then it is possible to view a list of outstanding orders and invoiced orders within 

the SOP.  Click on the drop down arrow next to the Transactions button on the toolbar and select either 

Invoiced Orders or Outstanding Orders.  This brings up a grid, similar to the products and customers grid 

that shows a list of all the types of transactions selected.   

Figure 14-1 - Customer Details Form 

If it is required that a rep takes over another rep’s customers on a temporary basis then it is preferable 

to use the Edit Reps functionality rather than editing the reps’ customers individually.  See section 17.4 

for more details. 
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16 Searching 
It is possible to perform a search on all the main grids used within SOP.  These main grids are: 

• Orders – Current, All and Exported orders 

• Products 

• Customers 

• Transactions – Outstanding Orders and Invoiced Orders 

Click the Search button on the 

toolbar when one of these 

grids is displayed on screen to 

bring up the search pane as 

shown in Figure 16-1. 

To search the grid, select the 

search field from the drop 

down box and enter the search term in the Search For box.  Click Find to filter the grid below by the 

criteria entered.  

The current filter can be cancelled and the view reset by clicking the Show All button. 

17 Configuration Options 
The vast majority of SOP configuration options are set upon installation but there are a number of 

simple configuration options that may need to be changed from time to time.   

17.1 Order Hold Reasons 
SOP can be set up so that orders that 

match certain criteria are automatically 

held in the system.  The holding of an 

order simply means that SOP will not 

include such orders in the order extract 

that is imported into Intact. 

These ‘Order Hold Reasons’ are 

configured using the Order Hold 

Reasons dialog, which is accessed by 

clicking View → Order Hold Reasons.  

This dialog is shown in Figure 17-1. 

Use the checkboxes next to each 

reason to enable/disable each one.  If an order matches any of the reasons that are ticked then it will be 

held.  You cannot take an order off hold if it meets any of these criteria. 

Figure 16-1 - Search Pane 

Figure 17-1 - Order Hold Reasons 
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If an order is on hold for any of the reasons and you try and you try and take it off hold, the order will 

remain on hold and you will be notified why.  If you still wish to take the order off hold it is necessary to 

resolve the reason it is being held first. 

17.2 Order Sources 
When entering an order in SOP there is a drop down box of Order Sources.  These items are configured 

using the Order Sources dialog which is accessible by selecting View → Order Sources. 

A new order source can be added by clicking the Add button.  You can edit the name of an existing 

source by clicking the Edit button.  The default order source is selected by highlighting it and clicking the 

Set Default button. 

17.3 Currencies 
The currencies within the 

SOP system are setup using 

the currencies dialog shown 

in Figure 17-2 which is 

accessed by selecting View → 

Currencies.  

This screen is populated 

when the back office data is 

imported into the system and 

therefore the currencies here 

should reflect those that your 

company uses. 

A new currency can be added to the list by clicking the New button. 

Edit an existing currency e.g. its exchange rate by highlighting it in the grid and pressing the Edit button. 

A currency can be deleted from SOP by highlighting it and clicking the Delete Button. 

If you wish to import the currency table (from the back office import data) click the Import button. 

 

 

 

 

 

Figure 17-2 - Currencies Dialog 



16 | P a g e  
 

17.4 Reps 
You can view and edit information 

regarding all of the sales reps using 

the Edit Reps dialog which is 

opened by clicking Tools → Edit 

Reps and is shown in Figure 17-3. 

This list is initially populated when 

a back office import takes place.  A 

new rep is generated every time a 

new rep code is found on a 

customer record. 

You can Add, Edit or Delete reps by 

clicking the appropriate buttons. 

Highlighting a rep and clicking the Edit button brings up the Rep Details dialog as shown in Figure 17-4. 

This screen is divided into three tabs for easier navigation.  The Details and Handset Type tabs contain 

fields that relate to the rep and 

the handset they are using.  

The Coverage tab is of 

particular importance as it is 

here that temporary rep 

coverage can be configured.  If 

you wish to let a particular rep 

download another rep’s 

customers to his/her handset 

then you would use this screen.     

By checking the boxes next to 

the reps in the list, the current 

reps coverage will be extended 

to include the default 

customers for the rep that is 

ticked.  By selecting the ALL 

checkbox then the rep will be able to download the data relating to all of the customers in the system.  

This setting is convenient if a particular rep is unavailable for a period of time and you wish to have 

another rep covering their customers.  

17.5 Users 
The users of the SOP system are configured using the Edit Users dialog which is opened by clicking Tools 

→ Edit Reps.  You can add a user to the system by clicking the New button and edit existing users by 

highlighting them and clicking the Edit button. 

Figure 17-4 - Rep Details Dialog 

Figure 17-3 - Edit Reps Dialog 
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18 Maintenance 

18.1 Compacting the Database 
When back office data is imported into the SOP the database is compacted automatically which removes 

any unnecessary transaction logs, thus reducing the size of the database file.  It may be necessary to 

compact the database from time to time, especially if numerous transactions have been processed, as 

compacting the database will reduce the footprint of the SOP system on your computer. 

To manually compact the database select Tools → Data → Compact Database. 

18.2 Clearing the Database 
 

 

To clear all the data from the SOP system, select Tools → Data → Clear All.   

19 Housekeeping 
Several of the processes within the SOP system can be scheduled to occur at set intervals throughout 

the day.  Some processes are required to be scheduled such as the e-mailing functionality.  The 

application that is responsible for these tasks is the SOP Housekeeper and is automatically launched 

upon start up of the computer. The SOP application does not have to be running in order for the 

Housekeeper to function but both applications can function side by side during the working day. 

The housekeeper program runs in the system tray, at 

the bottom right of the screen (next to the clock) and 

the icon for it looks like this - . 

To open the housekeeper for editing the schedule, 

right click on the icon in the system tray and select 

Edit Schedule.  The opens the housekeeper 

configuration screen which lists the task that are 

available to be scheduled.  This screen shows you if 

the task is enabled, when it was last run and when it 

will run next.  To edit the scheduling of a process, highlight it and click the Edit Process button which will 

open the Configure Process dialog shown in Figure 19-1. 

Enable/disable the process by using the Enable Process checkbox on this screen.  The frequency of the 

execution of this process can be configured using the Frequency fields and the operating times set using 

the Operating Times fields at the bottom.  The process can be set to only operate on certain days of the 

week by using the Operating Days checkboxes on the right.  Click OK to save the changes to this process. 

Figure 19-1 - Configure Process Dialog 

Note:  This action CLEARS ALL YOUR DATA.  Only use this functionality of you have been told to do 

so by Computoy.  This operation is NOT REVERSABLE.  
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While the housekeeper scheduling screen is open, the housekeeping processes are all paused.  Do not 

forget to close the scheduling screen when you are finished by clicking the OK button. 

When a housekeeping process is running the icon on the task bar will change to the Running Process 

icon ( ). 

 

 


